gugldirty.blogg.se

Bugzilla release notes
Bugzilla release notes









bugzilla release notes
  1. #Bugzilla release notes install#
  2. #Bugzilla release notes update#
  3. #Bugzilla release notes Patch#
  4. #Bugzilla release notes software#
  5. #Bugzilla release notes code#

All contributions are gratefully appreciated and eagerly accepted. KDE is always looking for new volunteers and contributions, whether it is help with coding, bug fixing or reporting, writing documentation, translations, promotion, money, etc.

#Bugzilla release notes software#

KDE is a Free Software community that exists and grows only because of the help of many volunteers that donate their time and effort. If you like what the team is doing, please let them know! You can provide feedback direct to the developers via the #Plasma IRC channel, Plasma-devel mailing list or report issues via Bugzilla. You can give us feedback and get updates on our social media channels:ĭiscuss Plasma 5 on the KDE Forums Plasma 5 board. Community instructions to compile it Source Info Page Feedback

#Bugzilla release notes install#

You can install Plasma 5 directly from source. Package download wiki page Source Downloads Note that packages of this release might not be available on all distributions at the time of this announcement. Download live images with Plasma 5 Download Docker images with Plasma 5 Package Downloadsĭistributions have created, or are in the process of creating, packages listed on our wiki page. Docker images also provide a quick and easy way to test Plasma. What do we do in the case of attempted cross product modification? I'd suggest we just die with a call to ThrowUserError with a message stating that you are modifiying a milestone that doesn't belong to the product.The easiest way to try it out is with a live image booted off a USB disk. Perhaps the delete call should be something like this:ĭELETE Another problem is that the milestone ids being submitted in the hashes may not belong to the product specified in the REST call. RFC7231 says that a payload within a DELETE has "no defined semantics". POST - Create a list of milestones in product 101.ĭELETE - Delete a list of milestones in product 101.

#Bugzilla release notes update#

PUT - Update a list of milestones in product 101. GET - Get a list of milestones for product 101. Product is the resource being manipulated. Ok, so just to make sure I understand correctly how we want to do this. So maybe not having get() for everything is not the best thing. But on the other hand having too many ways to get the same information will just end up being confusing to the end user and more work to document. Originally I figured when someone wanted to get a list of milestones for a product they could just do /rest/product/Bugzilla?include_fields=milestones which would be equivalent to /rest/milestones/Bugzilla I suppose.

#Bugzilla release notes code#

If it is simple and not much duplication I suppose there is no harm to add simple get() methods to Component/Milestone/Version but maybe we should break out some of the duplicate code into separate Util type module and then reuse it in Milestone.get and Product.get. I think we would need to ask ourselves, how will people actually use the API? Will anyone ever just want to get information about a single milestone or component, or will they most likely always want to get a list of milestones or list of components in a single product? I suspect the latter will be true most of the time. > function and you should use the Product level get function to find this > IMO it would make sense to update the docs to say that there's no get

bugzilla release notes

> should remove the Milestone get to be consistent. > I noticed that the Component rest endpoint has no get function, maybe we > also available in the Product.get call.

#Bugzilla release notes Patch#

> Part of this patch includes a Milestone.get function. (In reply to Matt Tyson from comment #11) I didn't read the code very carefully, because all of my comments above are the same as in bug 419568 and they should be addressed first. If the complexity comes from supporting milestones from several products at once, then this support should be dropped. Why defining _get_milestone_objects() instead of using params_to_objects() as we do everywhere else? This method seems overly complex to me.

bugzilla release notes

>+ my ($self, $params, $milestone) = return filter($params,, MAPPED_SETTERS) >= added file 'Bugzilla/WebService/Milestone.pm' Since this patch is much like the patch for bug 777047, most of my comments on bug 777047 apply to this patch as well plus the following: Patch to add Milestone.pm to WebService API (v1)











Bugzilla release notes